Ubuntu: wxWidgets te oud



Toen ik FileZilla weer een keer wilde gebruiken om enkele bestanden naar mijn server te kopiëren, merkte ik dat FileZilla onder Ubuntu niet meer werkte, doordat het crashte door een segmentatiefout. Dit werd veroorzaakt door een oude versie van wxWidgets.

Programma’s die wxWidgets gebruiken zijn onder andere aMule, Audacity, BitTorrent, FileZilla, RapidSVN, TortoiseCVS en TrueCrypt. Ik weet dat aMule, Audacity en FileZilla met de oude versie problemen hebben. Deze programma’s crashen bij bepaalde acties.

Oplossing

Oplossing voor dit probleem is het installeren van de laatste stabiele versie (2.8.12) van wxWidgets.

Voordat we gaan doen zorgen we eerst dat Ubuntu bijgewerkt is. Open Updatebeheer en installeer eventuele updates.
Nu kunnen we wxWidgets gaan updaten.

  1. Open een terminalvenster en voer de volgende commando’s uit:
    cd ~/Bureaublad
    wget http://apt.wxwidgets.org/key.asc
    sudo apt-key add key.asc

    Sluit het terminalvenster nog niet.
  2. Open Softwarebronnen.
  3. Klik op het tabblad ‘Overige software’.
  4. Klik op de ‘Toevoegen…’ button.
  5. Voer op de APT-regel het volgende in;
  6. Klik op de Sluiten button
  7. Voer in het nog steeds openstaande terminalvenster het commando sudo apt-get update uit.
  8. Sluit het terminalvenster.
  9. Open Updatebeheer en update wxWidgets.
    Als er niets verschijnt kan je op de Controleren button klikken.

Als het goed is moet het programma nu niet meer crashen. Als dat wel het geval is dan ligt het niet aan wxWidgets.

4 thoughts on “Ubuntu: wxWidgets te oud

  1. Hallo Leo,
    Niets dan lof, omdat ik audacity heb geinstalleerd heb ik wxwidgets geupdate zoals hierboven beschreven voor ubuntu 10.04.
    Nou krijg ik elke keer dit “W: GPG-fout: http://apt.wxwidgets.org lucid-wx Release: De volgende ondertekeningen waren ongeldig: BADSIG 0E0BCE7F53B087BC Robin Dunn
    W: GPG-fout: http://ppa.launchpad.net lucid Release: De volgende ondertekeningen waren ongeldig: BADSIG 3CEAAF36ECF4C854 Launchpad PPA for troorl
    W: GPG-fout: http://ppa.launchpad.net lucid Release: De volgende ondertekeningen waren ongeldig: BADSIG 6AF0E1940624A220 Launchpad PPA for TualatriX” te zien.
    Wat kan ik hier aan doen?

  2. De foutmelding “”W: GPG-fout: http://apt.wxwidgets.org lucid-wx Release: De volgende ondertekeningen waren ongeldig: BADSIG 0E0BCE7F53B087BC Robin Dunn” krijg je omdat je de authenticatie sleutel niet (goed) hebt toegevoegd. Voer de commando’s
    cd ~/Bureaublad
    wget http://apt.wxwidgets.org/key.asc
    sudo apt-key add key.asc

    nog een keer uit.
    Hetzelfde geld voor de de sleutels van troorl en Tualatrix. Waarom deze fout gaan weet ik ook niet. Heeft niets met wxWidgets te maken. Voeg de sleutels opnieuw toe of verwijder de PPA eerste en voeg deze dan opnieuw toe.

Vragen, opmerkingen en meningen over dit artikel kan je hier kwijt:

Vul je gegevens in of klik op een icoon om in te loggen.

WordPress.com logo

Je reageert onder je WordPress.com account. Log uit / Bijwerken )

Twitter-afbeelding

Je reageert onder je Twitter account. Log uit / Bijwerken )

Facebook foto

Je reageert onder je Facebook account. Log uit / Bijwerken )

Google+ photo

Je reageert onder je Google+ account. Log uit / Bijwerken )

Verbinden met %s