Upgrade naar Ubuntu 8.10: Installeren van OpenOffice.org 3.0


(laatst aangepast op 1 februari 2009; zie aan het eind van dit artikel voor de wijzigingen)
Ubuntu 8.10 bevat bij de release OpenOffice.org 2.4.1. De meeste van ons zouden graag OpenOffice.org 3.0 hebben vanwege de voordelen. De meest significante voordelen zijn:

  • OpenOffice kan nu Microsoft Office 2007 (Windows) bestanden en Microsoft Office 2008 (Mac) bestanden openen.
  • OpenOffice ondersteunt nu ODF (Open Document Format) 1.2.
  • OpenOffice kan nu PDF bestanden importeren (extension voor versie 3.0).
  • OpenOffice 3.0 is sneller.

Dit artikel beschrijft hoe je in Ubuntu 8.10 gemakkelijk OpenOffice.org 2.4.1 kan upgraden naar versie 3.0.

Na het schrijven van dit artikel is OpenOffice 3.0 ook beschikbaar gekomen in een PPA voor Ubuntu 8.04.
Dit artikel geldt voor Ubuntu 8.04 (Hardy Heron) en 8.10 (Intrepid Ibex) en werkt niet op oudere versies van Ubuntu.
Als je Ubuntu 8.04 gebruikt, vervang in OpenOffice 3.0 repository toevoegen stap 4 intrepid door hardy.

Ubuntu updaten

Voor dat we beginnen met het installeren van OpenOffice 3.0 gaan we er eerst voor zorgen dat Ubuntu up-to-date is.

  1. Ga naar Systeem –> Beheer –> Update-manager.
  2. In het Update-manager venster klik op de Controleren button.
  3. Installeer eventuele updates.

OpenOffice 3.0 repository toevoegen

  1. Voer het volgende commando in een terminalvenster uit voor de PGP-sleutel van de repository toe te voegen:
    gpg --no-default-keyring --keyring /tmp/tmp.keyring --keyserver keyserver.ubuntu.com --recv D2BB86E0EBD0F0A43D4DB3A760D11217247D1CFF && gpg --no-default-keyring --keyring /tmp/tmp.keyring --export --armor D2BB86E0EBD0F0A43D4DB3A760D11217247D1CFF | sudo apt-key add - && rm /tmp/tmp.keyring
  2. Ga naar Systeem –> Beheer –> Softwarebronnen.
  3. In het Softwarebronnen venster ga naar het het ‘Software van derden’ tabblad.
  4. Klik op de Toevoegen button.
  5. In het ‘Voer de volledige APT-regel in van de pakketbron die U wilt toevoegen’ venster vul ‘deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main’ bij ‘APT-regel:’ in en klik op de ‘Bron toevoegen’ button.
  6. Klik in het venster ‘De informatie over beschikbare software is verouderd’ op de Herladen button.

Upgrade OpenOffice.org naar versie 3.0

  1. Als het goed is verschijnt nu het update icoon in de systray. Klik er op en voer de update uit.
  2. In het Samenvatting venster klik op de Toepassen button.

Dat is alles. Je hebt nu OpenOffice 3.0.

Snelstarter aanzetten

Als je in versie 2.4.1 de snelstarter nog niet ingeschakeld hebt, dan kan je dat nu doen. OpenOffice zal hierdoor sneller laden en openen.

  1. Ga in OpenOffice naar Extra –> Opties.
  2. In het ‘Opties – OpenOffice.org’ venster, klik links in het subvenster op OpenOffice.org. Klik daarna op Geheugen.
  3. Vink in het rechter subvenster de optie ‘Snelstarter in systeemvak inschakelen’ aan.

Gewijzigd op 1 februari 2009: De PPA heeft inmiddels een GPG-sleutel. Deze is toegevoegd in het artikel.
Gewijzigd op 5 januari 2009: Inmiddels is er ook een PPA voor OpenOffice 3.0 onder Ubuntu 8.04. Dit opgenomen in het artikel. Met dank aan Jeroen. Zie reactie 18.


68 thoughts on “Upgrade naar Ubuntu 8.10: Installeren van OpenOffice.org 3.0

  1. @Rob en Tom, OK, dit is nieuw, maar wel een goede zaak. De PPA’s worden ondertekend en zijn dan dus veilig. Voer in een terminalvenster het volgende commando uit:
    gpg --no-default-keyring --keyring /tmp/awn.keyring --keyserver keyserver.ubuntu.com --recv D2BB86E0EBD0F0A43D4DB3A760D11217247D1CFF && gpg --no-default-keyring --keyring /tmp/awn.keyring --export --armor D2BB86E0EBD0F0A43D4DB3A760D11217247D1CFF | sudo apt-key add - && rm /tmp/awn.keyring
    Dit voegt de sleutel toe en dan kan je in Synaptic de pakketten gebruiken.
    Artikel is aangepast.

  2. Ik heb de updates nu kunnen binnenhalen. Ik ben juist begonnen met ubuntu
    en dus nog een newbie. Heb toevallig je blog ontdekt. Alvast bedankt Leo.

  3. Leo,

    ik krijg de foutmelding dat niet alle updates kunnen worden geïnstalleerd. Bij controle blijken slechts vier pakketten aangevinkt te staan, de rest heeft geen vinkje. Ben ook een newby en was juist zo blij met dit stappenplan voor OpenOffice 3. Suggesties?

    Groet van Gijs

  4. @Gijs, Ik heb het nog even gecontroleerd, maar in de PPA zit de gehele versie 3.01 van OpenOffice.
    Kan je even aangeven op welke versie van Ubuntu je zit? En welke versie van OOo je nu hebt.

    Als je Ubuntu 8.04 hebt, dan moet je (zoals aangegeven in het rode gedeelte) bij de APT-regel intrepid vervangen door hardy.

  5. Ik heb nog steeds problemen om 3.0 te installeren onder Ubuntu 8.10. Melding na ingeven commando ‘ggp –no default ………. etc”:

    gpg: Waarschuwing: onveilige eigendomsinstellingen van configuratie bestand ‘/home/homedirectory/.gnupg/gpg.conf’
    gpg: externe programma’s zijn niet toegestaan omdat bestanbds permissies onveilig zijn
    gpg: communicatie fout met de sleutelserver: general error
    gpg: sleutelserver opvraging is mislukt: general error

    In het bestand gpg.conf vind ik alleen de regel:
    # FILE CREATED BY SEAHORSE

    Als ik me m’n cursussen Linux nog goed herinner is dit slechts commentaar.

    Zou je nog eens een poging willen doen om me verder op weg te helpen?

    Bvd,
    Freek Goeree

  6. @Freek, dit betekent dat de rechten van gpg.conf gewijzigd zijn. Dit kan je herstellen door de volgende commando’s in een terminalvenster uit te voeren:
    chmod 700 ~/.gnupg
    chmod 600 ~/.gnupg/*

  7. Bedankt voor je hulp. Echter ik begrijp het steeds minder. Ik heb alle commando’s uitgevoerd met “sudo”. Dit blijkt echter niet te werken. Reden lijkt te zijn, dat je met “sudo” gewoon “user” blijft. (Gecontroleerd met “whoami”). En dan werkt het niet.
    Ik heb nu “su” gebuikt en met “whoami” zie ik dan dat ik root ben. En nu werkt het wel.

    Het is met computers blijkbaar als met Maggi: Een beetje (veel) van Maggi, en een beetje van jezelf en we komen een heel eind -:)

    Nogmaals heel erg bedankt.

  8. @Freek, ik ben blij dat het nu werkt. De twee commando’s had je ook met je eigen user kunnen uitvoeren (daarom had ik er ook geen sudo voor gezet).

    Sudo moet echter ook werken. Voer het commando sudo whoami uit. Als je root als resultaat krijgt is alles goed. Zo niet meldt je dan weer even en we lossen het op.

  9. Bij het updaten van Ubuntu – Systeem –> Beheer –> Update-manager – Controleren –
    Kreeg ik de onderstaande foutmelding:

    GPG-fout: http://packages.medibuntu.org intrepid Release: De volgende ondertekeningen konden niet geverifieerd worden omdat de publieke sleutel niet beschikbaar is: NO_PUBKEY 2EBC26B60C5A2783Ophalen van cdrom:[Ubuntu 8.10 _Intrepid Ibex_ – Release i386 (20081029.5)]/dists/intrepid/main/binary-i386/Packages.gz Om deze APT deze CD te laten herkennen kunt u best apt-cdrom gebruiken. ‘apt-get update’ is niet in staat om nieuwe CDs toe te voegen is mislukt

    Ophalen van cdrom:[Ubuntu 8.10 _Intrepid Ibex_ – Release i386 (20081029.5)]/dists/intrepid/restricted/binary-i386/Packages.gz Om deze APT deze CD te laten herkennen kunt u best apt-cdrom gebruiken. ‘apt-get update’ is niet in staat om nieuwe CDs toe te voegen is mislukt

    Ophalen van sommige indexbestanden is mislukt, deze zijn of genegeerd, of er zijn oudere versies van gebruikt.

    Hoe nu verder??

    Het is trouwens de 1e keer dat ik deze melding krijg bij t updaten

    Lioba

    • Lioba, jij krijgt de foutmelding op Medibuntu. Dit heeft trouwens niets met dit artikel te maken (niet vervelend bedoeld). Je hebt om een andere reden de medibuntu repository toegevoegd.
      Om van de foutmelding af te komen moet je het volgende commando in een terminalvenster uitvoeren:
      sudo apt-get update && sudo apt-get install medibuntu-keyring && sudo apt-get update

      • Hoi Leo,
        Ik was net begonnen met stap 1 van het upgraden,Upgrade naar Ubuntu 8.10: Installeren van OpenOffice.org 3.0, vandaar de melding.
        Lioba

        • Ok, dan kan inderdaad een foutmelding komen van een softwarebron waar nog geen GPG-sleutel voor is toegevoegd. De afgelopen tijd hebben (bijna) alle softwarebronnen een verificatiesleutel gekregen.

          • Hoi Leo,

            Ik blijf de foutmelding houden maar heb nu wel OpenOffice.org 3.0 en dat terwijl ik pas bij stap 2 was, OpenOffice 3.0 repository toevoegen, punt 6 gaf dezelfde foutmelding.

            Nou ja, ik ga nu maar naar de laatste stap, de snelstarter aanzetten.

            Groetjes Lioba

  10. @Lioba, heb je de sleutel toegevoegd en daarna de softwarebronnen herladen? Zo ja, dan is er toch iets fout gegaan met de sleutel.
    Ik heb het bij mij gecontroleerd en daar werkt het gewoon.
    Controleer in Systeem –> Beheer –> Softwarebronnen of je in het tabblad Authenticatie een entry ziet voor Medibunutu met als code 0C5A2783 voor Medibuntu. Zo ja dan is het goed, en moet je nog even herladen. Het makkelijkst kan je dit doen door in het tabblad ‘Software van derden’ het pakket Medibuntu uit te vinken en daarna gelijk weer aan te vinken. Daarna venster sluiten en herladen als je de vraag krijgt.

    Hopelijk werkt dit voor je.

    • @Leo, helaas het werkt niet. Bij het tabblad Authenticatie staat geen Medibuntu, als ik daarna in tabblad Software voor derden het Medibuntu uitvink en afsluit blijf ik steeds dezelfde foutcode krijgen.

      • Lioba, mijn vermoeden was dus inderdaad correct. De sleutel wordt bij jouw niet toegevoegd. Ondanks dat je het commando sudo apt-get update && sudo apt-get install medibuntu-keyring && sudo apt-get update hebt uitgevoerd. Reden is mij onbekend.
        Probeer de sleutel eens op te voeren door een ander commando in het terminalvenster uit te voeren:
        wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update
        Heb je nu wel een entry in het tabblad Authenticatie bij Systeem –> Beheer –> Softwarebronnen?

  11. Werkt prima. Ook voor een linux newbie zoals ik.
    Duidelijk, helder, kort en bondig.

    site staat bij de favorieten.

    gr Martin

  12. Installatie werkt prima….geen fouten tot nu toe….goeie uitleg.

    Door op het forum te kijken als beginner, kwam ik op deze link….een must-have link voor iedere beginner.

    bedankt

    Groeten
    HPS58

  13. Allereerst complimenten voor de inhoud, erg handig allemaal.

    Voordat ik deze site ontdekt had, middels een engelstalige site OO 3.01 geinstalleerd door eerst de oude te vervanfen en dan een NL versie OO 301 te installeren. Alles werkt prima en snel, behalve ODBC. Volgens manuals moet het een en ander al erin staan voor het lezen van een MS Access (mdb) bv, maar in de dropdown staan niets.

    Graag advies in deze, aangezien ik nergens wat kan vinden over ODBC installeren voor OO in Ubuntu 8.10/

    Mvg
    JB

  14. Beste Leo heb op mijn Hardy nu ook maar OO3 erop gezet , met behulp van Uw aanwijzingen.
    Alles ging zeer vlot en goed , heb daarna mijn PC ge reboot en het mapje van OO3 staat in mijn verborgen bestanden (prima).
    Nog even de oude map met OO2 verwijderd en alles is clean.
    Had nog een kleine vraag , als er update zijn (eventueel) voor OO3 bekomen we die dan ook automatisch ?
    Met vriendelijke groet Wanda.

    • Wanda, goede vraag. Ja je krijgt de updates automatisch zolang je de softwarebron van openoffice-pkgs softwareborn aangevinkt laat staan. Je krijgt de update van Ubuntu of van deze softwarebron. Dus van diegene die eerder is.

  15. Alles werkt supper, echter enkel in het engels.
    Als ik de NL pakketten probeer te installeren, krijg ik de melding dat de pakketten niet beschikbaar zijn voor deze localisatie??

    Enig idee hoe dit kan worden omzeild?

    • Ranime,
      – Ga naar Systeem –> Beheer –> Taalondersteuning (in het Engels System –> Maintenance –> Language support).
      – Klik op ‘Taal toevoegen/verwijderen…’ en vink ‘Dutch; Flemish’ aan.
      – Klik op de ‘Wijzigingen doorvoeren, button.
      – Kies in het Taal venster voor beide opties Nederlands (Nederland).
      – Meld je af en log opnieuw in.

      – Open OpenOffice writer (Toepassingen –> Kantoor –> ‘OpenOffice.org Tekstverwerker’.
      – Ga in OpenOffice writer naar Extra –> ‘Opties…’.
      – Klik links op Taalinstellingen –> Talen.
      – Hier kan je nu je taalkeuze instellen.

      Ik hoor wel of het gelukt is.

      • Hoi Leo,

        Om de één of andere reden wordt openoffice.org-l10n-nl niet geaccepteerd. Ik heb nu de .debs gedownload van nl.openoffice.org en deze geïnstalleerd samen met de sun jre 6.0 voor 64-bits. en het werkt :)

        Bedankt voor je inspanning! Misschien is dit een bug in de 64 bits versie.

        • Ranime, Klopt, de .debs werkt. Zoals je hieronder bij reactie 20 kan lezen is dit een compilatiefout in de PPA en ligt het niet aan Ubuntu of aan de 64 bits versie.

          • Hoi Leo,

            Wederom bedankt voor je reactie.

            De .debs hebben ook wat eigenaardigheden die ik niet zo maar opgelost krijg. ik blijf voorlopig nog maar werken met 2.4, totdat de compilatie fouten zijn opgelost ;)

            Groetjes

  16. Leo,

    De installatie onder Ubuntu 8.10 verliep vlekkeloos, alleen vanwege diverse problemen die ik niet kon oplossen heb ik alles er weer afgegooid en heb ik Ubuntu 8.04 hardy geinstalleerd. De problemen die ik onder 8.10 had met geluid en VLC zijn nu opgelost, alleen de installatie van OpenOffice 3.00 werkte nu niet vlekkeloos. Ik heb gedaan wat er in de handleiding staat, krijg ook bericht dat er updates beschikbaar zijn, alleen wel met de volgende melding:

    /home/hps58/Bureaublad/Schermafdruk-update-manager.png

    Als ik dan kies voor een gedeeltelijke upgrade krijg ik het volgende te zien:

    /home/hps58/Bureaublad/Schermafdruk-update-manager-1.png

    Dit zijn de instellingen onder softwarebronnen:

    /home/hps58/Bureaublad/Schermafdruk-Softwarebronnen.png

    Wat doe ik verkeerd?

    Groeten
    HPS58

      • Herman, zo te zien is de softwarebron correct toegevoegd.
        Ik heb even in de PPA gekeken, maar OpenOffice 3.1.0 heeft voor hardy en intrepid een gebroken pakket en wel openoffice.org-l10n – 1:3.1.0-1ubuntu1~hardy1. Dit sinds gisteren. Als het goed is zie je deze ook uitgegrijst in updatebeheer. Ligt dus niet aan jou, maar aan de PPA. Wordt binnenkort opgelost, omdat terwijl ik dit schrijf ze deze aan het hercompileren zijn.
        Probeer morgen of overmorgen nog een keer. Compileren duurt lang. Laat me maar weten als het wel of niet gelukt is (dan kijk ik nog een keer).

        • Leo,

          bedankt voor je antwoord, ik zal het deze week nog een keer proberen. Dat zal dan morgen worden, daarna ben ik een paar dagen weg en kan ik pas zondagavond weer zien of het lukt.

          Ik hou je op de hoogte

          groeten
          herman

          • Herman, de compilatie is weer fout gegaan. Ik zie niet wanneer er weer een nieuwe compilatie komt. Zie reactie 19 als je toch de nieuwe versie wilt installeren. Als je wilt wachten hou ik je wel op de hoogte.

            • Leo,

              Ik had het gelezen, bedankt voor je antwoord. Ik wacht wel even een paar dagen, misschien dat het na dit weekend wel lukt….heb nu niet direct nodig en heb voor vandaag even genoeg op de pc gewerkt.

              Hou me op de hoogte en als het maandag of dinsdag nog niet wil, ga ik suggestie 19 wel opvolgen.

              Groeten
              herman

            • Leo,

              Het probleem van de update is nu opgelost…ik heb net een melding gehad voor een update en ja hoor nu heb ik ook Office versie 3.1

              Bedankt voor de steun tot zover.

              Groeten
              Herman

  17. ja maar ksnap er nix van :(
    ben een enorme leek :(
    kheb gewoon open office 3.1 geinstalleerd.
    Maar verder geraak ik niet :(
    Kan je me op mijn mail verder helpen?
    eefje_vl at hotmail

Vragen, opmerkingen en meningen over dit artikel kan je hier kwijt:

Vul je gegevens in of klik op een icoon om in te loggen.

WordPress.com logo

Je reageert onder je WordPress.com account. Log uit / Bijwerken )

Twitter-afbeelding

Je reageert onder je Twitter account. Log uit / Bijwerken )

Facebook foto

Je reageert onder je Facebook account. Log uit / Bijwerken )

Google+ photo

Je reageert onder je Google+ account. Log uit / Bijwerken )

Verbinden met %s