TDF introduceert LibreOffice 3.5



The Document Foundation introduceert LibreOffice 3.5, hun derde major release. Ze noemen dit zelf “the best free office suite ever”.

Belangrijkste nieuwe features:

  • Base: nieuwe filter voor PostgreSQL databases
  • Calc: meerdere regel input bar
  • Calc: meerdere selecties in autofilter
  • Impress: verbeterde import voor Microsoft PowerPoint (incl. smart arts)
  • Impress: nieuwe importfilter voor Microsoft Visio tekeningen
  • Writer: verbeterde font scherpte (hinting) voor hoogwaardige documenten
  • Writer: tellen van het aantal woorden in een document terwijl je typt
  • Writer: nieuwe gebruikersinterface voor paginahoofd (header), paginavoet (footer) en pagina-einde
  • Writer: verbeterde importfunctie voor RTF-documenten

Voor een meer gedetailleerd overzicht kan je hier terecht: LibreOffice.org (Engels).

LibreOffice PPA

LibreOffice kan je het beste upgraden via de LibreOffice PPA. Voer de volgende commando’s uit in een terminalvenster om de PPA toe te voegen:
sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update

Als het goed is komt Updatebeheer automatisch op. Zo niet, open Updatebeheer dan handmatig.

Natuurlijk kan je deze ook via de LibreOffice website downloaden en installeren,maar zoals jullie weten ben ik hier geen voorstander van, omdat dan de Ubuntu regels niet worden gevolgd. Beter is het om de PPA te gebruiken.

About these ads

4 reacties op “TDF introduceert LibreOffice 3.5

  1. Dag Leo,
    Ik heb Ubuntu 11.10 oneiric 64-bit op mijn laptop geïnstalleeerd. Overeenkomstig jouw artikel heb ik daar inmiddels ook de ppa:libreoffice/ppa bij geplaatst. Bij de laatste update heb ik wel LibreOffice 3.5.1.2 in mijn systeem binnengehaald. Maar bij die installatie gaf Updatebeheer problemen aan voor het volgende onderdeel van die update.

    Overige updates (LP-PPA-libreoffice)

    LibreOffice extension for importing PDF documents
    libreoffice-pdfimport (grootte 558 kB)

    LibreOffice extension for size-efficient presentations
    libreoffice-presentation-minimizer (grootte 302 kB)

    LibreOffice Impress extension for a separate presenter’s console
    libreo-presenter-console (grootte 721 kB)

    LibreOffice extension for working with MediaWiki articles
    libreoffice-wiki-publisher (grootte 449 kb)

    Er zijn vier updates geselecteerd. De updates zijn wel gedownload maar nog niet geïnstalleerd.

    Als ik deze ga installeren, komt het volgende bericht

    Pakkethandeling is mislukt

    De installatie of verwijdering van een softwarepakket is mislukt.

    De daarbij vermelde details zijn als volgt:

    installArchives() failed: (Reading database …
    (Reading database … 5%%
    (Reading database … 10%%
    (Reading database … 15%%
    (Reading database … 20%%
    (Reading database … 25%%
    (Reading database … 30%%
    (Reading database … 35%%
    (Reading database … 40%%
    (Reading database … 45%%
    (Reading database … 50%%
    (Reading database … 55%%
    (Reading database … 60%%
    (Reading database … 65%%
    (Reading database … 70%%
    (Reading database … 75%%
    (Reading database … 80%%
    (Reading database … 85%%
    (Reading database … 90%%
    (Reading database … 95%%
    (Reading database … 100%%
    (Reading database … 299061 files and directories currently installed.)
    Preparing to replace libreoffice-wiki-publisher 1.1.1+LibO3.5.0-1ubuntu3~oneiric1 (using …/libreoffice-wiki-publisher_1.1.1+LibO3.5.1-1ubuntu1~oneiric1_all.deb) …

    FOUT: unopkg kan niet worden gestart. Het vergendelingsbestand geeft aan dat het al wordt uitgevoerd. Als dat niet van toepassing is verwijder dan het vergrendelingsbestand op:
    /var/lib/libreoffice/share/prereg/.lock
    dpkg: error processing /var/cache/apt/archives/libreoffice-wiki-publisher_1.1.1+LibO3.5.1-1ubuntu1~oneiric1_all.deb (–unpack):
    subprocess new pre-installation script returned error exit status 1
    Preparing to replace libreoffice-presentation-minimizer 1.0.3+LibO3.5.0-1ubuntu3~oneiric1 (using …/libreoffice-presentation-minimizer_1.0.3+LibO3.5.1-1ubuntu1~oneiric1_amd64.deb) …

    FOUT: unopkg kan niet worden gestart. Het vergendelingsbestand geeft aan dat het al wordt uitgevoerd. Als dat niet van toepassing is verwijder dan het vergrendelingsbestand op:
    /var/lib/libreoffice/share/prereg/.lock
    dpkg: error processing /var/cache/apt/archives/libreoffice-presentation-minimizer_1.0.3+LibO3.5.1-1ubuntu1~oneiric1_amd64.deb (–unpack):
    subprocess new pre-installation script returned error exit status 1
    Preparing to replace libreoffice-presenter-console 1.1.0+LibO3.5.0-1ubuntu3~oneiric1 (using …/libreoffice-presenter-console_1.1.0+LibO3.5.1-1ubuntu1~oneiric1_amd64.deb) …

    FOUT: unopkg kan niet worden gestart. Het vergendelingsbestand geeft aan dat het al wordt uitgevoerd. Als dat niet van toepassing is verwijder dan het vergrendelingsbestand op:
    /var/lib/libreoffice/share/prereg/.lock
    dpkg: error processing /var/cache/apt/archives/libreoffice-presenter-console_1.1.0+LibO3.5.1-1ubuntu1~oneiric1_amd64.deb (–unpack):
    subprocess new pre-installation script returned error exit status 1
    Preparing to replace libreoffice-pdfimport 1.0.5+LibO3.5.0-1ubuntu3~oneiric1 (using …/libreoffice-pdfimport_1.0.5+LibO3.5.1-1ubuntu1~oneiric1_amd64.deb) …

    FOUT: unopkg kan niet worden gestart. Het vergendelingsbestand geeft aan dat het al wordt uitgevoerd. Als dat niet van toepassing is verwijder dan het vergrendelingsbestand op:
    /var/lib/libreoffice/share/prereg/.lock
    dpkg: error processing /var/cache/apt/archives/libreoffice-pdfimport_1.0.5+LibO3.5.1-1ubuntu1~oneiric1_amd64.deb (–unpack):
    subprocess new pre-installation script returned error exit status 1
    No apport report written because MaxReports is reached already
    Processing triggers for libreoffice-common …
    Errors were encountered while processing:
    /var/cache/apt/archives/libreoffice-wiki-publisher_1.1.1+LibO3.5.1-1ubuntu1~oneiric1_all.deb
    /var/cache/apt/archives/libreoffice-presentation-minimizer_1.0.3+LibO3.5.1-1ubuntu1~oneiric1_amd64.deb
    /var/cache/apt/archives/libreoffice-presenter-console_1.1.0+LibO3.5.1-1ubuntu1~oneiric1_amd64.deb
    /var/cache/apt/archives/libreoffice-pdfimport_1.0.5+LibO3.5.1-1ubuntu1~oneiric1_amd64.deb
    (einde details)

    Leo, ik durf veel, maar dit vind ik ingewikkeld. Kun jij hieruit voor mij een handzame instructie maken, zodat ik deze problemen met mijn updatebeheer opgelost krijg? (De eerste keer gaf Updatebeheer het advies om de ppa libreoffice te verwijderen. Er zou sprake zijn van een gebroken pakket Er zouden problemen zijn met een python-bestand. Het was dus een foei-verhaal. Ik heb daarna de ppa-libreoffice verwijderd met behoud van de reeds geïnstalleerde bestanden, op de wijze zoals jij eerder beschreven hebt. Ook in etc/apt/sources.list.d heb ik libreoffice.list en libreoffice.list.save verwijderd. Daarna heb ik de ppa. Libreoffice weer geïnstalleerd met het bovenstaande resultaat. Het bestand python-software-propertys heb ik ook al eerder geïnstalleerd.

    Groetjes

    Dré Van Horen

    • Dré,

      Er zijn meer mensen die problemen hebben. Zie hier: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/960867

      Laten we maar eens kijken of we het opgelost krijgen. We gaan de volgende stappen doorlopen:
      - alle software-installatiepakketten sluiten
      - alle alle niet geconfigureerde pakketten configureren
      - de lock verwijderen
      - ppa-purge installeren(deze stap kan je overslaan als je ppa-purge al geïnstalleerd hebt)
      - ppa van LibreOffice verwijderen en LibreOffice automatisch terugzetten naar de officiële Ubuntu versie
      - Officiële Ubuntu versie van LibreOffice verwijderen
      - ppa weer toevoegen
      - LibreOffice installeren

      1) Sluit alle software-installatiepakketten zoals Ubuntu Softwarecentrum, Updatebeheer en Synaptic.
      2) Open een terminalvenster (dan kunnen we direct zien of er fouten optreden) en voer de volgende commando’s uit:
      sudo dpkg --configure -a
      sudo rm /var/lib/libreoffice/share/prereg/.lock
      sudo apt-get install ppa-purge
      sudo ppa-purge ppa:libreoffice/ppa
      sudo apt-get purge libreoffice*
      sudo apt-get autoclean
      sudo apt-get autoremove
      sudo add-apt-repository ppa:libreoffice/ppa
      sudo apt-get update && sudo apt-get install libreoffice

      Hopelijk gaat het nu wel goed.

      Als het nog niet werkt, dan voer je nu het bovenstaande weer uit, maar nu alleen tot en met het ppa-purge commando.
      Dan heb je tenminste de officiële Ubuntu versie van LibreOffice.
      Ik zou dan wachten tot de bug is opgelost.

      • Het is mij gelukt! Alleen bij het de eerste keer uitvoeren van de voorlaatste opdracht: sudo add-apt-repository ppa:libreoffice/ppa werd een fout gemeld in mijn bestanden in etc/apt/sources.list.d. Daar kwam volgens de melding een derde regel “ain” in voor, die niet herkend werd. Met behulp van nautilus heb ik die regel verwijderd en vervolgens de opdracht opnieuw uitgevoerd. En daarna liep alles perfect! Leo, hartelijk dank voor je fantastische en snelle ondersteuning!

        Dré Van Horen

Vragen, opmerkingen en meningen over dit artikel kan je hier kwijt:

Vul je gegevens in of klik op een icoon om in te loggen.

WordPress.com logo

Je reageert onder je WordPress.com account. Log uit / Bijwerken )

Twitter-afbeelding

Je reageert onder je Twitter account. Log uit / Bijwerken )

Facebook foto

Je reageert onder je Facebook account. Log uit / Bijwerken )

Google+ photo

Je reageert onder je Google+ account. Log uit / Bijwerken )

Verbinden met %s